<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//content.jwplatform.com' /><link rel='dns-prefetch' href='//cookie-cdn.cookiepro.com' /><link rel='dns-prefetch' href='//syncaccess-swc-PR.syncronex.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//cdn.parkrecord.com' /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.parkrecord.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-polls-css'  href='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/plugins/wp-polls/polls-css-2.75.2.css' type='text/css' media='all' /><style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url(https://cdn.parkrecord.com/wp-content/plugins/wp-polls/images/default/pollbg.gif);border:1px solid #c8c8c8}</style><link rel='stylesheet' id='swift-main-css-css'  href='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/css/main.min-1568222283.css' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css-css'  href='https://fonts.googleapis.com/css?family=Heebo%3A400%2C700%7CLora%3A400%2C400i%2C700&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-css-css'  href='https://use.fontawesome.com/releases/v5.4.1/css/all.css?ver=5.0.13' type='text/css' media='all' /><link rel='stylesheet' id='weather-icons-css-css'  href='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/css/vendors/weather-icons/weather-icons.min-2.0.css' type='text/css' media='all' /><link rel='stylesheet' id='bootstrap-calendar-css-css'  href='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/css/vendors/bootstrap-datepicker/bootstrap-datepicker-1.8.0.css' type='text/css' media='all' /><link rel='stylesheet' id='fancybox-css-css'  href='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.css?ver=3.5.6' type='text/css' media='all' /><link rel='stylesheet' id='lightslider-css-css'  href='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/css/vendors/lightslider-1.1.6.css' type='text/css' media='all' /><link rel='stylesheet' id='lightgallery-css-css'  href='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/css/vendors/lightgallery-1.6.11.css' type='text/css' media='all' /> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery/3.3.1/jquery.min.js?ver=3.3.1'></script> <script type='text/javascript' onload="jwLibraryLoaded (jwLibraryCheck, true)" defer src='https://content.jwplatform.com/libraries/GbYFhgye.js?ver=1.0.0'></script> <script type='text/javascript'>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</script> <link rel='https://api.w.org/' href='https://www.parkrecord.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.parkrecord.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.parkrecord.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Record editorial: When people most affected by gun violence speak, we have an obligation to listen' href='https://www.parkrecord.com/opinion/record-editorial-when-people-most-affected-by-gun-violence-speak-we-have-an-obligation-to-listen/' /><link rel='next' title='Jim Jacobs’ sculptures focus on the ‘Imperfections That Render Us Visible’' href='https://www.parkrecord.com/entertainment/jim-jacobs-sculptures-focus-on-the-imperfections-that-render-us-visible/' /><meta name="generator" content="WordPress 5.2.3" /><link rel="canonical" href="https://www.parkrecord.com/news/jay-meehan-viva-mexico-and-throw-the-bums-out/" /><link rel='shortlink' href='https://www.parkrecord.com/?p=98285' /><link rel="alternate" type="application/json+oembed" href="https://www.parkrecord.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.parkrecord.com%2Fnews%2Fjay-meehan-viva-mexico-and-throw-the-bums-out%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.parkrecord.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.parkrecord.com%2Fnews%2Fjay-meehan-viva-mexico-and-throw-the-bums-out%2F&#038;format=xml" /> <script>window.SGPMPopupLoader=window.SGPMPopupLoader||{ids:[],popups:{},call:function(w,d,s,l,id){
									w['sgp']=w['sgp']||function(){(w['sgp'].q=w['sgp'].q||[]).push(arguments[0]);};
									var sg1=d.createElement(s),sg0=d.getElementsByTagName(s)[0];
									if(SGPMPopupLoader && SGPMPopupLoader.ids && SGPMPopupLoader.ids.length > 0){SGPMPopupLoader.ids.push(id); return;}
									SGPMPopupLoader.ids.push(id);
									sg1.onload = function(){SGPMPopup.openSGPMPopup();}; sg1.async=true; sg1.src=l;
									sg0.parentNode.insertBefore(sg1,sg0);
									return {};
								}};</script><script>SGPMPopupLoader.call(window,document,'script','https://popupmaker.com/assets/lib/SGPMPopup.min.js','3ae59d5c');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-851550877"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'AW-851550877');</script>  <script>gtag('event', 'conversion', {'send_to': 'AW-851550877/FXboCPrZnacBEJ3FhpYD'});</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
          (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
          m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-4028663-65', 'auto');
        ga('create', 'UA-4028663-63', 'auto', {'name': 'newTracker'});
 	      ga('require', 'displayfeatures');
	      ga('require', 'linkid');</script> <script>(function() {
			  var _fbq = window._fbq || (window._fbq = []);
			  if (!_fbq.loaded) {
			    var fbds = document.createElement('script');
			    fbds.async = true;
			    fbds.src = '//connect.facebook.net/en_US/fbds.js';
			    var s = document.getElementsByTagName('script')[0];
			    s.parentNode.insertBefore(fbds, s);
			    _fbq.loaded = true;
			  }
			  _fbq.push(['addPixelId', '356889104458573']);
			  
			  })();
			  window._fbq = window._fbq || [];
			  window._fbq.push(["track", "PixelInitialized", {}]);</script><noscript> <img height="1" width="1" border="0" alt="" style="display:none" src="https://www.facebook.com/tr?id=356889104458573&ev=PixelInitialized" /> </noscript><meta name="google-site-verification" content="lswJ5n4RlboI8uwObzOgeTRIgG70mAN_k_vOQivQ4B4" /><meta name="__sync_contentCategory" content="Paid" /><meta name="__sync_tenantId" content="swc_gt"><link rel="shortcut icon" href="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/favicon.ico"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/favicon-32x32.png"><title>Jay Meehan: Viva Mexico, and throw the bums out | ParkRecord.com</title><meta name="description" content="It was love at first sight, first taste, first aroma, first hearing, first touch. I became immediately smitten at sensory, molecular, and intellectual levels. Out of the blue came" /><meta name="keywords" content="MEXICAN, GRITO, HIDALGO, INDEPENDENCE, MEXICO, OROZCO, SAN, STOP, ADD, ALFARO" /><meta property="og:title" content="Jay Meehan: Viva Mexico, and throw the bums out"/><meta property="og:description" content="It was love at first sight, first taste, first aroma, first hearing, first touch. I became immediately smitten at sensory, molecular, and intellectual levels. Out of the blue came"/><meta property="og:url" content="https://www.parkrecord.com/news/jay-meehan-viva-mexico-and-throw-the-bums-out/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content=""/><meta property="og:image" content="https://www.parkrecord.com/wp-content/uploads/sites/11/2019/04/pr-facebook.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="sniply-options" content="block" /><meta property="article:publisher" content="https://www.facebook.com/parkrecord" /><meta name="author" content="Jay Meehan" /><meta property="og:type" content="article" /> <script type="application/ld+json">{
				  "@context": "https://schema.org",
				  "@type": "NewsArticle",
				  "mainEntityOfPage": {
				    "@type": "WebPage",
				    "@id": "https://google.com/article"
				  },
					
					"isAccessibleForFree": "False",
	  			"hasPart": {
	    		"@type": "WebPageElement",
	    		"isAccessibleForFree": "False",
	    		"cssSelector": ".swift-paywall"
  			},
				  "headline": "Jay Meehan: Viva Mexico, and throw the bums out",
				  "image": [
				    "https://www.parkrecord.com/wp-content/uploads/sites/11/2019/04/pr-facebook.jpg"
				   ],
				  "datePublished": "2019-09-18 06:00:01",
				  "dateModified": "2019-09-17 16:33:37",
					"author": {
						"@type": "Person",
						"name": "Jay Meehan"
					},
				   "publisher": {
				    "@type": "Organization",
				    "name": "ParkRecord.com",
				    "logo": {
				      "@type": "ImageObject",
				      "url": "https://www.parkrecord.com/wp-content/uploads/sites/11/2019/08/pr-logo-2x.png"
				    }
				  },
				  "description": "It was love at first sight, first taste, first aroma, first hearing, first touch. I became immediately smitten at sensory, molecular, and intellectual levels. Out of the blue came a crush on the entire Mexican culture. I’m going to stop here to tie on the headband I picked up many years ago while checking out&hellip;"
				}</script><meta property="fb:app_id" content="258274121221291" /><meta name="pubdate" content="20190918"></head><body class="post-template-default single single-post postid-98285 single-format-standard parkrecord category-columns category-news category-opinion"><div id="fb-root"></div> <script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=258274121221291&autoLogAppEvents=1';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script> <script>function get_cookie_value(a) {
					var b = document.cookie.match('(^|;)\\s*' + a + '\\s*=\\s*([^;]+)');
					return b ? b.pop() : '';
				}
				var free_site = false;
var show_survey = true;
				var syncwall_cookie = get_cookie_value('syncwall-active-subscriber');

				if ( syncwall_cookie !== null ) {
					//console.log('SwiftDebug | js free_site: ' + free_site );
					//console.log('SwiftDebug | js show_survey: ' + show_survey );
					//console.log('SwiftDebug | js syncwall-active-subscriber cookie value: ' + syncwall_cookie );
				}</script> <script>if ( (free_site === true && show_survey === true) || (free_site === false && ( show_survey === true && (syncwall_cookie !== null && syncwall_cookie !== "true") ) ) ) {

	        console.log("SwiftDebug | Google Survey enabled");

					(function() {
	          var ARTICLE_URL = window.location.href;
	          var CONTENT_ID = 'everything';
	          document.write(
	            '<scr'+'ipt '+
	            'src="//survey.g.doubleclick.net/survey?site=_gqywj56nzbgqhbp2opnwi23cre'+
	            '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	            '&amp;random='+(new Date).getTime()+
	            '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	        })();

	      }
	      else {
	        console.log("SwiftDebug | Google Survey disabled");
	      }</script> <header><nav id="nav-publication" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"> <a class="logo navbar-brand" href="https://www.parkrecord.com"> <img  src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/08/pr-logo.png" srcset="https://www.parkrecord.com/wp-content/uploads/sites/11/2019/08/pr-logo-2x.png 2x" alt="ParkRecord.com Logo"> </a><div class="align-self-end"> <span class="tag-line navbar-text">Park City and Summit County News</span></div></div><div class="d-flex"><form class="search-form form-inline" action="https://www.parkrecord.com/search-results/"> <input class="search-input form-control" type="search" placeholder="Search" aria-label="Search" name="q"> <button class="search-button" type="submit"><i class="fas fa-search"></i></button> <input type="hidden" name="sort" value="desc" /> <input type="hidden" name="range" value="10/18/2005" /></form><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="/forecast/"> <i class="wi wi-day-sunny"></i> 41&deg; </a></li><li class="nav-item nav-account"> <a class="nav-link" href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=0ParkR">My Account</a> | <span id="logged-out"><a class="nav-link" id="loginBtn" href="javascript:void(0);">Login</a></span> <span id="logged-in" style="display: none;"><a class="nav-link" id="logoutBtn" href="javascript:void(0);">Logout</a></span></li></ul></div></nav><nav id="nav-main" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"><div id="nav-main-menu"><ul class="nav-menu navbar-nav"><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-8" href="https://www.parkrecord.com/">News</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-8" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/news/park-city/">Park City</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/news/summit-county/">Summit County</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/news/business/">Business</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/news/education/">Education</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.legacy.com/obituaries/parkrecord/">Obituaries</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://www.parkrecord.com/sports/">Sports</a></li><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-24" href="https://www.parkrecord.com/entertainment/">Entertainment</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-24" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/entertainment/sundance-slamdance/">Sundance-Slamdance</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/entertainment/calendar/">Calendar</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/entertainment/add-an-event/">Add an Event</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-32" href="https://www.parkrecord.com/opinion/">Opinion</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-32" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/opinion/editorial/">Our View</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/opinion/columns/">Columns</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/opinion/letters/">Letters</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/opinion/submit-a-letter/">Submit a Letter</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-93763" href="https://www.parkrecord.com/magazines/">Magazines</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-93763" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/special-sections/park-city-home/">Park City Home</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=2a299a76-98cc-424c-a94e-98d3999c286c">Park City's Best</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=d9893866-3fe8-4217-86d5-ca46e153b9a5">Milepost</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=a3322e7e-9150-46ac-b2f3-f02888c13fe1">Film Festival</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.parkrecord.com/special-sections/park-city-parent/">Park City Parent</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=5908ef4d-ff03-45c9-8437-c32adcfd5a72">Adventure Guide</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://www.parkrecordonline.com/restaurants/category/location/">Dining</a></li><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-95005" href="http://classifieds.parkrecord.com/">Classifieds</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-95005" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.parkrecord.com/category/Employment">Jobs</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.parkrecord.com/category/Real-Estate-For-Sale">Real Estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.parkrecord.com/category/Transportation">Autos</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://secure.adpay.com/AdEntry.aspx?p=9183&brand=ParkRecord">Place ad</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=68feaf59-c822-447c-bfda-dedc8908b6e0">Real Estate</a></li></ul></div></div><div class="d-flex"> <button class="subscribe-button btn" type="button"><a href="https://www.parkrecord.com/subscribe/">Subscribe</a></button></div></nav><nav id="nav-mobile" class="d-lg-none d-xl-none py-1 shadow-sm"><div class="d-flex justify-content-between align-items-center"><div class="m-3"> <button class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"> <i class="fas fa-bars mr-1"></i> <i class="fas fa-times mr-1"></i> </button></div><div class="logo"> <a class="navbar-brand" href="https://www.parkrecord.com"> <img  src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/08/pr-logo.png" srcset="https://www.parkrecord.com/wp-content/uploads/sites/11/2019/08/pr-logo-2x.png 2x" alt="ParkRecord.com Logo"> </a></div><div class="m-3"> <button class="user-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-account" aria-controls="nav-mobile-account" aria-expanded="false" aria-label="Toggle account"> <i class="fas fa-user mr-1"></i> <i class="fas fa-times mr-1"></i> </button> <button class="search-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-search" aria-controls="nav-mobile-search" aria-expanded="false" aria-label="Toggle search"> <i class="fas fa-search ml-1"></i> <i class="fas fa-times mr-1"></i> </button></div></div></nav><nav id="nav-mobile-menu" class="hamburger-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-8" aria-expanded="false"> <span>News</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-8" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.parkrecord.com/">View Section ></a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/news/park-city/" >Park City </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/news/summit-county/" >Summit County </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/news/business/" >Business </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/news/education/" >Education </a></li><li><a class="nav-link infant" href="https://www.legacy.com/obituaries/parkrecord/" >Obituaries </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://www.parkrecord.com/sports/" > <span>Sports</span> </a></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-24" aria-expanded="false"> <span>Entertainment</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-24" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.parkrecord.com/entertainment/">View Section ></a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/entertainment/sundance-slamdance/" >Sundance-Slamdance </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/entertainment/calendar/" >Calendar </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/entertainment/add-an-event/" >Add an Event </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-32" aria-expanded="false"> <span>Opinion</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-32" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.parkrecord.com/opinion/">View Section ></a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/opinion/editorial/" >Our View </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/opinion/columns/" >Columns </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/opinion/letters/" >Letters </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/opinion/submit-a-letter/" >Submit a Letter </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-93763" aria-expanded="false"> <span>Magazines</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-93763" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.parkrecord.com/magazines/">View Section ></a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/special-sections/park-city-home/" >Park City Home </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=2a299a76-98cc-424c-a94e-98d3999c286c" >Park City's Best </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=d9893866-3fe8-4217-86d5-ca46e153b9a5" >Milepost </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=a3322e7e-9150-46ac-b2f3-f02888c13fe1" >Film Festival </a></li><li><a class="nav-link infant" href="https://www.parkrecord.com/special-sections/park-city-parent/" >Park City Parent </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=5908ef4d-ff03-45c9-8437-c32adcfd5a72" >Adventure Guide </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://www.parkrecordonline.com/restaurants/category/location/" > <span>Dining</span> </a></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-95005" aria-expanded="false"> <span>Classifieds</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-95005" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="http://classifieds.parkrecord.com/">View Section ></a></li><li><a class="nav-link infant" href="http://classifieds.parkrecord.com/category/Employment" >Jobs </a></li><li><a class="nav-link infant" href="http://classifieds.parkrecord.com/category/Real-Estate-For-Sale" >Real Estate </a></li><li><a class="nav-link infant" href="http://classifieds.parkrecord.com/category/Transportation" >Autos </a></li><li><a class="nav-link infant" href="https://secure.adpay.com/AdEntry.aspx?p=9183&brand=ParkRecord" >Place ad </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=68feaf59-c822-447c-bfda-dedc8908b6e0" > <span>Real Estate</span> </a></li><li class="nav-item"><a class="nav-link" href="https://www.parkrecord.com/subscribe/"><span>Subscribe</span></a></li></ul></nav><div id="nav-mobile-account" class="user-button-dropdown collapse position-absolute d-lg-none d-xl-none shadow-sm"><div class="row"><div class="col"><a href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=0ParkR">My Account</a></div><div class="col"> <span id="logged-out2"><a id="loginBtn2" href="javascript:void(0);">Login</a></span> <span id="logged-in2" style="display: none;"><a id="logoutBtn2" href="javascript:void(0);">Logout</a></span></div></div></div><div id="nav-mobile-search" class="search-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><form class="search-form form-inline d-flex" action="https://www.parkrecord.com/search-results/"> <input class="search-input form-control flex-fill" type="search" aria-label="Search" name="q" placeholder="enter search terms"> <button class="search-button btn" type="submit">Search</button> <input type="hidden" name="sort" value="desc" /> <input type="hidden" name="range" value="10/18/2005" /></form></div></header><main><div class="container"><nav id="nav-reader-tools" class="navbar navbar-expand d-none d-lg-flex"><ul class="nav-menu navbar-nav ml-auto"><li id="menu-item-93892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93892"><a href="http://edition.pagesuite-professional.co.uk//launch.aspx?pbid=21d71112-03a8-40b8-b169-6831a53edf84">E-Edition</a><span>|</span></li><li id="menu-item-93893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93893"><a href="https://www.parkrecord.com/contribute/">Contribute</a><span>|</span></li><li id="menu-item-93894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93894"><a href="https://www.parkrecord.com/advertise/">Advertise</a><span>|</span></li><li id="menu-item-93895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93895"><a href="https://secure.adpay.com/AdEntry.aspx?p=9183">Place an Ad</a><span>|</span></li></ul></nav><div id="primary"><div class="container-fluid" style="margin-bottom: 20px;"><div class="row justify-content-center"><div id="ad-top" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-top');
				})</script> </div></div></div><div id="layout-single"><div class="d-lg-flex"><article class="flex-fill"><h1>Jay Meehan: Viva Mexico, and throw the bums out</h1><p class="article-meta"><a href="https://www.parkrecord.com/recent-stories/news">News</a> <span class="text-muted">| September 18, 2019</span></p><div id="article-byline"><div class="d-flex"><div class="editor-image"><img src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2018/01/Jay-Meehan-6-26-14manip11-124x150.jpg" alt="Jay Meehan" /></div><div class="editor-name"><h6><a href="https://www.parkrecord.com/profile/jay-meehan/" rel="author">Jay Meehan</a></h6><p><a href="mailto:" rel="author"></a></p></div><div class="article-social ml-auto"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Jay Meehan: Viva Mexico, and throw the bums out&url=https://www.parkrecord.com/?p=98285" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=258274121221291&href=https://www.parkrecord.com/news/jay-meehan-viva-mexico-and-throw-the-bums-out/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item d-sm-none d-md-block"> <a class="nav-link" href="mailto:?subject=Jay Meehan: Viva Mexico, and throw the bums out&body=It was love at first sight, first taste, first aroma, first hearing, first touch. I became immediately smitten at sensory, molecular, and intellectual levels. Out of the blue came a crush on the entire Mexican...%0D%0A%0D%0Ahttps://www.parkrecord.com/news/jay-meehan-viva-mexico-and-throw-the-bums-out/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item d-sm-none d-md-block"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div><div class="p402_premium"><div class="swift-paywall"><p class="PR-Body Copy">It was love at first sight, first taste, first aroma, first hearing, first touch. I became immediately smitten at sensory, molecular, and intellectual levels.</p><p class="PR-Body Copy">Out of the blue came a crush on the entire Mexican culture.</p><p class="PR-Body Copy">I’m going to stop here to tie on the headband I picked up many years ago while checking out the sunset from a hilltop near the border town of Tecate. Then, I’ll put Linda Ronstadt’s Canciones De Mi Padre on a loop and add just a smidgen more Kahlúa to my café Mexicana. Typing at this level requires a fair amount of nurturing.</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-parallax2" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-parallax2');
				})</script> </div></div></div><p class="PR-Body Copy">Have I mentioned that Monday was Mexican Independence Day? Back during the early morning of Sept. 16, 1810, in what was then the village of Delores, New Spain, Padre Miguel Hidalgo y Costilla rang his church bell and issued the call to arms for independence from Spanish rule.</p><figure class="wp-block-pullquote p402_hide"><blockquote><p>The finest art is confrontational, they say and the murals of Orozco, Diego Rivera, and David Alfaro Siqueiros seemed to always stop us dead in our tracks.”</p></blockquote></figure><p class="PR-Body Copy">I don’t go as far as throwing open my windows and re-enacting “the cry,” (el grito), on the eve of the anniversary in the manner each President of Mexico performs annually. Now, if I actually possessed the same bell as Hidalgo, as they do, I might. The revolution took 11 years with Hidalgo, having been captured and beheaded, not being around for the endgame.</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-big-box4" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-big-box4');
				})</script> </div></div></div><p class="PR-Body Copy">My confusion concerning the particulars of Mexican Independence Day back then had been driven by ignorance similar in profile to that of other “whites” north of the border. It’s not that I mistook it for Cinco de Mayo and the Battle of Pueblo against the French, it’s just that basically, I was clueless. That would all change, however. Ol’ Miguel still has his head in my  memory.</p><p class="PR-Body Copy">We were mostly, if not totally, unaware concerning these historical events as our raggedy bunch ascended the marble staircase inside the Palacio de Gobierno in Guadalajara back in early ’67. It would be the mural at the top, however, that would take us aback.</p><p class="PR-Body Copy">It was from there the angry visage of our Mexican freedom-fighter parish priest hero glared down from above. The work, by José Clemente Orozco, appeared almost IMAX-sized. “The People and its Leaders” featured a grimacing Hidalgo issuing the “el grito de Delores.” He held both torch and attitude. Gave us the shivers, it did.</p><p class="PR-Body Copy">The finest art is confrontational, they say and the murals of Orozco, Diego Rivera, and David Alfaro Siqueiros seemed to always stop us dead in our tracks. Of course, it could be said the peyote bin in the produce section of the Gran Mercado San Juan de Dios did the same.</p><p class="PR-Body Copy">Each year, similar recollections, spurred on possibly by nectar fashioned from the blue agave plant, arrive on cue. Fleeting glimpses from long-term memory dealing with adventurous romanticisms along the west coast of Mexico also usually make an entrance.</p><p class="PR-Body Copy">I must admit that, although I have felt much love wherever I hung my hat during this life, I never felt more at home in a new cultural environment than on my first trip down that coastline. From Mazatlan to San Blas and Matanchén to Puerto Vallarta and Mismaloya to Barre de Navidad and Manzanillo, the hits just kept on coming.</p><p class="PR-Body Copy">Another break in the narrative appears called for to add yet another stiffening additive to the mug in question. It’s a rule of thumb that around Mexican Independence Day the bottom of the vessel should never see the light.</p><p class="PR-Body Copy">Our mission that trip had to do with helping one of our tribe resolve his recently received draft notice and, although we pretty much knew how it would go, we pretended to ponder. I went along to provide the recently honorably discharged point of view.</p><p class="PR-Body Copy">With the additional assistance of a friend who provided both her driving skills and an old-school Plymouth, we set off for San Blas. What we hadn’t counted on was getting ran-off the first night by federales who had received the go ahead from Nixon’s bunch to reduce the influx of counterculture types invading their landscape.</p><p class="PR-Body Copy">I suppose much of the joy I get in putting this narrative into the record, pun intended as it were, comes as a reaction to the white supremacist leanings of Agent Orange and the Republicans bouncing along at the end of his puppet strings.</p><p class="PR-Body Copy">It’s sort of an el grito, a cry to throw the bums out.<p class="PR-Body Copy"><p class="PR-Body Copy"><em>Jay Meehan is a culture junkie and has been an observer, participant, and chronicler of the Park City and Wasatch County social and political scenes for more than 40 years.</em></p></p></div><p class="article-tagline"><em></em></p></div> <script type="text/javascript">try { _402_Show(); } catch(e) {}</script> <hr /><div id="fb-comment-policy"><p>Start a dialogue, stay on topic and be civil.<br /> If you don't <a href="https://www.parkrecord.com/comment-policy">follow the rules</a>, your comment may be deleted.</p></div><div class="fb-comments" data-href="https://www.parkrecord.com/?p=98285" data-width="100%" data-numposts="3"></div><hr /><div id="single-flipp-script"><div id="circularhub_module_15506"></div> <script src="//api.circularhub.com/15506/8a8f233706837170/circularhub_module.js"></script> </div><hr /><div class="row"><div class="card-item col-md-12"><div class="module module-dual-column card shadow-sm"><div class="card-header"><i class="far fa-newspaper icon-section"></i> Columns</div><div class="card-body"><section><article><div class="row no-gutters"><div class="col card-text"><h4><a href="https://www.parkrecord.com/news/jay-meehan-viva-mexico-and-throw-the-bums-out/">Jay Meehan: Viva Mexico, and throw the bums out</a></h4><p class="card-meta"><span class="text-muted">September 18, 2019</span></p><p class="card-excerpt d-lg-none d-xl-block"></p></div></div></article><hr /><div class="row"><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.parkrecord.com/opinion/tom-clyde-the-quinns-junction-park-and-ride-or-something/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/09/tomclyde-BWnew93-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /><noscript><img width="150" height="150" src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/09/tomclyde-BWnew93-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.parkrecord.com/opinion/tom-clyde-the-quinns-junction-park-and-ride-or-something/">Tom Clyde: The Quinn&#8217;s Junction Park and Ride – or something</a></h6><p class="card-meta"><span class="text-muted">September 14, 2019</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.parkrecord.com/opinion/teri-orr-fall-is-time-for-forgiveness-and-reflection-and-finding-god-in-all-the-right-places/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-150x150.jpg 150w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-300x300.jpg 300w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-768x768.jpg 768w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-1024x1024.jpg 1024w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1.jpg 1333w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-150x150.jpg 150w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-300x300.jpg 300w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-768x768.jpg 768w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1-1024x1024.jpg 1024w, https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/04/Tericolumn-tpr-012718-1.jpg 1333w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.parkrecord.com/opinion/teri-orr-fall-is-time-for-forgiveness-and-reflection-and-finding-god-in-all-the-right-places/">Teri Orr: Fall is time for forgiveness and reflection and finding God in all the right places</a></h6><p class="card-meta"><span class="text-muted">September 13, 2019</span></p></div></div></article><hr class="d-md-none d-lg-none d-xl-none" /></div><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.parkrecord.com/opinion/jay-meehan-what-i-learned-as-a-cosmic-cowboy-dj/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/09/Jay-Meehan-6-26-14manip88-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /><noscript><img width="150" height="150" src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/09/Jay-Meehan-6-26-14manip88-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.parkrecord.com/opinion/jay-meehan-what-i-learned-as-a-cosmic-cowboy-dj/">Jay Meehan: What I learned as a cosmic cowboy DJ</a></h6><p class="card-meta"><span class="text-muted">September 12, 2019</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.parkrecord.com/opinion/tom-clyde-noise-has-become-the-new-secondhand-smoke/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/09/tomclyde-BWnew92-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /><noscript><img width="150" height="150" src="https://cdn.parkrecord.com/wp-content/uploads/sites/11/2019/09/tomclyde-BWnew92-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.parkrecord.com/opinion/tom-clyde-noise-has-become-the-new-secondhand-smoke/">Tom Clyde: Noise has become the new secondhand smoke</a></h6><p class="card-meta"><span class="text-muted">September 8, 2019</span></p></div></div></article></div></div><hr /></section> <a href="https://www.parkrecord.com/recent-stories/columns/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div></div></article><aside><div class="card-container row"><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box1"><div id="ad-big-box1" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box1');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-gallery module-c2 card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Top Jobs</h5><div id="carousel-93737" class="carousel slide" data-ride="carousel" data-interval="5000"><div class="carousel-inner"><div class="carousel-item active" style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Restaurant-Clubs/waitstaff-and-cooks/9-0000473098-01" target="_blank">Silver Summit Cafe</a></h5><h6>Waitstaff & Cooks</h6><p style="font-size:.875rem;"> <em></em><br><span>Silver Summit Caf&eacute; 6065 Silver Creek Dri, Park City, Ut 84098 The Silver Summit Cafe&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Restaurant-Clubs/executive-chefbusiness-partner/9-0000485156-01" target="_blank">Gateway Grille</a></h5><h6>Executive Chef/Business Partner</h6><p style="font-size:.875rem;"> <em></em><br><span>Gateway Grille Kamas Ut. We are seeking a motivated, creative, experienced, passionate Executive Chef to&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Government/recreation-director/9-0000485625-01" target="_blank">Summit County</a></h5><h6>Recreation Director</h6><p style="font-size:.875rem;"> <em></em><br><span>Recreation Director North Summit Recreation Special Service District is seeking a responsible and organized individual&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Building-Services/electricians/9-0000483454-01" target="_blank">Chesley Electric</a></h5><h6>Electricians</h6><p style="font-size:.875rem;"> <em></em><br><span>Electricians Chesley Electric is looking for Journeyman and Apprentice Electricians to join our team. Chesley&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Customer-Service/sales-associate/9-0000476406-01" target="_blank">7-Eleven</a></h5><h6>Sales Associate</h6><p style="font-size:.875rem;"> <em></em><br><span>Sales Associate Seeking friendly, customer-service oriented individuals to join our 7-Eleven team. Sales Associates are&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Education/spanish-teacher/9-0000482742-01" target="_blank">Silver Summit Academy</a></h5><h6>Spanish Teacher</h6><p style="font-size:.875rem;"> <em></em><br><span>South Summit School District is seeking applicants for a part-time Spanish Teacher at Silver Summit&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.parkrecord.com/ad/Employment/Customer-Service/recreation-front-desk-customer-service/9-0000485339-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://snmg.swift-ads.com/onlineimages/27/0000423527-01-0.jpg" alt="Recreation Front Desk Customer Service " style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Customer-Service/recreation-front-desk-customer-service/9-0000485339-01" target="_blank">PC MARC </a></h5><h6>Recreation Front Desk Customer Service</h6><p style="font-size:.875rem;"> <em></em><br><span>Recreation Front Desk Customer Service The PC MARC is looking for individuals to work in&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.parkrecord.com/ad/Employment/Office-Clerical/front-desk-associates/9-0000480713-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://snmg.swift-ads.com/onlineimages/13/0000480713-01-0.jpg" alt="Front Desk Associates" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Office-Clerical/front-desk-associates/9-0000480713-01" target="_blank">Saltz Plastic Surgery Spa Vitoria</a></h5><h6>Front Desk Associates</h6><p style="font-size:.875rem;"> <em></em><br><span>Saltz Plastic Surgery &amp; Saltz Spa Vitoria is hiring part-time Front Desk Associates Salt Lake&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Building-Services/heavy-equipment-operators-and-commercial-d/9-0000483966-01" target="_blank">Landscope, LLC</a></h5><h6>Heavy Equipment Operators & Commercial Drivers</h6><p style="font-size:.875rem;"> <em></em><br><span>General Contractor seeking experienced heavy equipment operators ($30-$32/hr) and commercial drivers ($25-$26/hr) for immediate full-time&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Health-Care/nurse-for-special-education/9-0000482730-01" target="_blank">South Summit School District</a></h5><h6>Nurse for special education</h6><p style="font-size:.875rem;"> <em></em><br><span>South Summit School District is seeking applicants for a full-time NURSE for special education 1&#58;1&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.parkrecord.com/ad/Employment/Media/ad-sales-digital-and-print/9-0000457315-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.parkrecord.com/data/images/0000457315-01.jpg" alt="Ad Sales Digital & Print" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Media/ad-sales-digital-and-print/9-0000457315-01" target="_blank">Park Record</a></h5><h6>Ad Sales Digital & Print</h6><p style="font-size:.875rem;"> <em></em><br><span>Advertising Sales Digital &amp; Print Specialist The Park Record and Parkrecord.com are located in Park&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.parkrecord.com/ad/Employment/Hospitality/food-and-beverage-front-office-housekeep/9-0000483188-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://snmg.swift-ads.com/onlineimages/61/0000398561-01-0.jpg" alt="Food & Beverage, Front Office, Housekeeping, Spa" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Hospitality/food-and-beverage-front-office-housekeep/9-0000483188-01" target="_blank">Hotel Park City</a></h5><h6>Food & Beverage, Front Office, Housekeeping, Spa</h6><p style="font-size:.875rem;"> <em></em><br><span>Food &amp; Beverage &#149; Director of Food &amp; Beverage &#149; Banquet Server &#149; Server -&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Other/sundance-institute-is-hiring/9-0000484166-01" target="_blank">Sundance Institute</a></h5><h6>Sundance Institute is hiring!</h6><p style="font-size:.875rem;"> <em></em><br><span>JOIN US AT SUNDANCE INSTITUTE! If you're looking for a place where creativity, passion, and&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Drivers/delivery-drivers/9-0000473106-01" target="_blank">Silver Summit Cafe</a></h5><h6>Delivery Drivers</h6><p style="font-size:.875rem;"> <em></em><br><span>Silver Summit Caf&eacute; 6065 Silver Creek Dri, Park City, Ut 84098 The Silver Summit Cafe&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.parkrecord.com/ad/Employment/Customer-Service/ski-rental-team/9-0000480356-01" target="_blank">JANS MOUNTAIN OUTFITTERS</a></h5><h6>Ski Rental Team</h6><p style="font-size:.875rem;"> <em></em><br><span>JANS MOUNTAIN OUTFITTERS is hiring for the upcoming ski season. Join our high end ski&hellip;</span></p></div></div></div><div class="carousel-nav d-flex justify-content-center"><a class="carousel-control-prev position-absolute" style="width:60px;height:40px;top:100px;left:-30px;" href="#carousel-93737" role="button" data-slide="prev"> <i class="fas fa-chevron-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#carousel-93737" data-slide-to="1" class="active"></li><li data-target="#carousel-93737" data-slide-to="2" class=""></li><li data-target="#carousel-93737" data-slide-to="3" class=""></li><li data-target="#carousel-93737" data-slide-to="4" class=""></li><li data-target="#carousel-93737" data-slide-to="5" class=""></li><li data-target="#carousel-93737" data-slide-to="6" class=""></li><li data-target="#carousel-93737" data-slide-to="7" class=""></li><li data-target="#carousel-93737" data-slide-to="8" class=""></li><li data-target="#carousel-93737" data-slide-to="9" class=""></li><li data-target="#carousel-93737" data-slide-to="10" class=""></li><li data-target="#carousel-93737" data-slide-to="11" class=""></li><li data-target="#carousel-93737" data-slide-to="12" class=""></li><li data-target="#carousel-93737" data-slide-to="13" class=""></li><li data-target="#carousel-93737" data-slide-to="14" class=""></li><li data-target="#carousel-93737" data-slide-to="15" class=""></li></ol><a class="carousel-control-next position-absolute" style="width:60px;height:40px;top:100px;right:-30px;" href="#carousel-93737" role="button" data-slide="next"> <i class="fas fa-chevron-right"></i> <span class="sr-only">Next</span> </a></div></div><hr /><a href="http://classifieds.parkrecord.com/category/Employment" class="card-link card-more" target="_blank">View more listings <i class="fas fa-angle-right"></i></a></div></div></div><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box2"><div id="ad-big-box2" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box2');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-e-edition card shadow-sm"><div class="card-header"><i class="fas fa-book-reader"></i> ParkRecord E-Edition</div><div class="card-body"><section> <iframe src="about:blank" style="border: none;" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://edition.pagesuite.com/miniflip/default.aspx?w=150&#038;pages=8&#038;autoflip=4000&#038;pbid=21d71112-03a8-40b8-b169-6831a53edf84"></iframe><noscript><iframe src="https://edition.pagesuite.com/miniflip/default.aspx?w=150&pages=8&autoflip=4000&pbid=21d71112-03a8-40b8-b169-6831a53edf84" style="border: none;"></iframe></noscript></section></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Upcoming Events</h5><hr /><div class="swift-paywall"><script type="text/javascript" src="//www.trumba.com/scripts/spuds.js"></script><br /> <script type="text/javascript">$Trumba.addSpud({
webName: "park-record",
spudType : "upcomingtable",
teaserBase : "https://www.parkrecord.com/entertainment/calendar"});</script></div></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><div class="swift-paywall"><div id="fb-root"></div><p><script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script></p><div style="width: 265px; height: 540px; margin: 0 auto;"><div class="fb-page" style="height: 540px; width: 265px;" data-href="https://www.facebook.com/parkrecord/" data-tabs="timeline" data-width="300" data-height="540" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/parkrecord/" class="fb-xfbml-parse-ignore"><p><a href="https://www.facebook.com/parkrecord/">Park Record</a></p></blockquote></div></div></div></div></div></div></div></aside></div></div></div></div></main><nav id="nav-mobile-footer" class="fixed-bottom d-lg-none d-xl-none"><ul class="nav nav-fill"><li class="nav-item"> <a class="nav-link " href="https://www.parkrecord.com"><i class="fas fa-home icon"></i><br/>Home</a></li><li class="nav-item"> <a class="nav-link " href="https://www.parkrecord.com/trending-stories/news/"><i class="fas fa-chart-line icon"></i><br/>Trending</a></li><li class="nav-item"> <a class="nav-link" id="mobile-back-to-top" href="#" class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"><i class="fas fa-bars icon"></i><br/>Sections</a></li></ul></nav><footer><div class="container"><nav id="nav-footer"><div class="row"><div class="col-md-5 offset-md-1 order-md-4"><ul class="nav nav-social justify-content-center justify-content-md-end"><li class="nav-item"><a class="nav-link" href="https://twitter.com/parkrecord" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-twitter icon-circle"></i> <i class="fab fa-twitter fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.facebook.com/parkrecord" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-facebook-f icon-circle"></i> <i class="fab fa-facebook-f fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://instagram.com/parkrecord" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-instagram icon-circle"></i> <i class="fab fa-instagram fa-stack-1x icon-social"></i> </span></a></li></ul></div><div class="col-md-2 nav-list order-md-1"><h6>Marketplace</h6><ul class="nav flex-md-column"><li id="menu-item-93887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93887"><a href="http://classifieds.parkrecord.com/category/Employment">Jobs</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93888"><a href="http://classifieds.parkrecord.com/category/Rentals">Rentals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93889"><a href="http://classifieds.parkrecord.com/category/Garage+Sales">Yard Sales</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93890"><a href="http://classifieds.parkrecord.com/">Classifieds</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93891"><a href="https://secure.adpay.com/AdEntry.aspx?p=9183&#038;brand=ParkRecord">Place Ad</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-2"><h6>Reader Tools</h6><ul class="nav flex-md-column"><li id="menu-item-93876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93876"><a href="https://parkrecordphoto.smugmug.com/">Buy Photos</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93877"><a href="http://edition.pagesuite-professional.co.uk//launch.aspx?pbid=21d71112-03a8-40b8-b169-6831a53edf84">E-Edition</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93879"><a href="https://swiftiservices.dticloud.com/cmo_cmo/subscriber/web/signin.html?siteId=0ParkR">Subscribe</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93880"><a href="https://www.parkrecord.com/contact-us/">Contact Us</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-95501" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-95501"><a href="https://parkrecord.secondstreetapp.com/Newsletter-Sign-up-Page">Newsletters</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93881"><a href="https://www.parkrecord.com/search-results/">Archives</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93882"><a href="https://www.parkrecord.com/opinion/submit-a-letter/">Submit a Letter</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93883" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93883"><a href="https://www.parkrecord.com/entertainment/add-an-event/">Submit an Event</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93884"><a href="http://www.swiftlocalsolutions.com/advertise-with-the-park-record">Advertise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93885"><a href="https://www.parkrecord.com/feed/">RSS</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93886"><a href="https://www.parkrecord.com/cookie-list/">Cookie List</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-3"><h6>News Neighbors</h6><ul class="nav flex-md-column"><li id="menu-item-93896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93896"><a href="https://www.aspentimes.com/">Aspen-Snowmass</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93897"><a href="http://www.summitdaily.com/">Breckenridge-Summit County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93898"><a href="https://www.craigdailypress.com/">Craig-Moffatt County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93899"><a href="http://www.postindependent.com/">Glenwood Springs-Rifle</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93900" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93900"><a href="https://www.steamboatpilot.com/">Steamboat Springs-Routt County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93901" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93901"><a href="https://www.vaildaily.com/">Vail-Eagle Valley</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-93902" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93902"><a href="https://www.skyhinews.com/">Winter Park-Granby-Grand County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div></div></nav><nav id="nav-footer-sub"><ul class="nav justify-content-center"><li id="menu-item-93869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93869"><a href="https://www.parkrecord.com/about-us/">About Us</a><span>|</span></li><li id="menu-item-93872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93872"><a href="https://www.parkrecord.com/terms-of-use/">Terms of Use</a><span>|</span></li><li id="menu-item-93873" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93873"><a href="https://www.parkrecord.com/privacy-policy/">Privacy Policy</a><span>|</span></li></ul><p class="text-center text-muted">©2005 - 2019 Swift Communications, Inc.</p></nav></div></footer> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-1066460699"></script> <script>window.dataLayer = window.dataLayer || [];
					  function gtag(){dataLayer.push(arguments);}
					  gtag('js', new Date());
					  gtag('config', 'AW-1066460699');</script> <script type="text/javascript">var _qevents = _qevents || [];

					(function() {
						var elem = document.createElement('script');
						elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
						elem.async = true;
						elem.type = "text/javascript";
						var scpt = document.getElementsByTagName('script')[0];
						scpt.parentNode.insertBefore(elem, scpt);
						})();

						_qevents.push({
						qacct:"p-a9NnlNKE5Euxo"
					});</script> <noscript><div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-a9NnlNKE5Euxo.gif" border="0" height="1" width="1" alt="Quantcast"/></div> </noscript> <script>jQuery(function($) {
						if ( $( '.wp-audio-shortcode' ).length ) {
							$( 'audio' ).mediaelementplayer({
								success: function(mediaElement, domObject, instance) {
		        			mediaElement.addEventListener('loadeddata', function() {
										ga( 'send', 'event', 'audio', 'play' );
										ga( 'newTracker.send', 'event', 'audio', 'play' );
				        	}, false);
									mediaElement.addEventListener('loadstart', function() {
										$( '.mejs-audio a.audio-download' ).click(function() {
											ga( 'send', 'event', 'audio', 'download' );
											ga( 'newTracker.send', 'event', 'audio', 'download' );
										});
									}, false);
		  					}
							});
						}
					});</script> <script>jQuery(function($) {
						$( '#mobile-app-link' ).click(function () {
							var eventLabel = $(this).attr('title');
							ga( 'send', 'event', 'Mobile App Link', 'Click', eventLabel );
							ga( 'newTracker.send', 'event', 'Mobile App Link', 'Click', eventLabel );
						});
					});</script> <link rel="manifest" href="/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'GqmLiDz6rzLpYgPfo1Ae1ikwfm9YZIblLyx3',
					});</script> <link rel="manifest" href="/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'GqmLiDz6rzLpYgPfo1Ae1ikwfm9YZIblLyx3',
					});</script><script type='text/javascript'>/* <![CDATA[ */ var pollsL10n = {"ajax_url":"https:\/\/www.parkrecord.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/plugins/wp-polls/polls-js-43ebe7e758c87557b052ede96a394500.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/vendors/popper-e47be35306050e853e3add13463757cf.js'></script> <script type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/js/vendors/recliner.min-0.2.3.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-1af3d29b1e947d95b0761765dbec88e1.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-datepicker-629a95c2652c8fd9bfb18daecad4cad0.js'></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.js?ver=3.5.6'></script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/vendors/lightslider-10043dddf442e6fb8b19540bbfccdbe0.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/vendors/lightgallery-e8f4c37dd9fc456c502a877b8f80f2b1.js'></script> <script type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/busting/11/wp-content/themes/swift-news-theme/assets/js/vendors/if-4-bootstrap-breakpoint.min-1.0.0.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var more_briefs = {"ajaxurl":"https:\/\/www.parkrecord.com\/wp-admin\/admin-ajax.php","briefs_nonce":"3b1c2269eb"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/main-dd99eb1e14bffa9be66bae9115398f8b.js'></script> <script type='text/javascript' src='https://cookie-cdn.cookiepro.com/consent/fefe8bb0-1050-4769-8d38-b5f55bd88e26.js?ver=1.0'></script> <script type='text/javascript'>function OptanonWrapper() { }</script> <script type='text/javascript' src='https://syncaccess-swc-PR.syncronex.com/swc/PR/api/scripts/syncwall?ver=1.0.0'></script> <script data-minify="1" type='text/javascript' src='https://cdn.parkrecord.com/wp-content/cache/min/11/wp-content/themes/swift-news-theme/assets/js/vendors/syncwall-login-api-fadec510a502e0ca6922ebbce1a04d4a.js'></script> <script type='text/javascript'>var swiftSiteID = 'PR'</script> <script type='text/javascript' src='https://cdn.parkrecord.com/wp-includes/js/wp-embed.min.js'></script> <script>var loggedIn = ( readCookie("syncwall-authToken") == null ) ? 'no' : 'yes';
var swiftLanguage = ( accessCookie("swift_language") == null ) ? 'english' : accessCookie("swift_language");
ga('set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'Jay Meehan','dimension7': '','dimension8': '2019-09-18','dimension9': '37779305','dimension10': '','dimension12': '2019-09-18 06:00:01','dimension13': '1','dimension14': 'article','dimension15': '759','dimension16': 'home','dimension18': swiftLanguage});
ga('newTracker.set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'Jay Meehan','dimension7': '','dimension8': '2019-09-18','dimension9': '37779305','dimension10': '','dimension12': '2019-09-18 06:00:01','dimension13': '1','dimension14': 'article','dimension15': '759','dimension16': 'home','dimension18': swiftLanguage});

	      var gaUserId = readCookie("sync-subscriberId");
	      if ( gaUserId ) {
	        ga('set', 'userId', gaUserId );
	        ga('newTracker.set', 'userId', gaUserId );
	      }
			ga('provide', 'adblockTracker', function(tracker, opts) {
			  var ad = document.createElement('ins');
			  ad.className = 'AdSense';
			  ad.style.display = 'block';
			  ad.style.position = 'absolute';
			  ad.style.top = '-1px';
			  ad.style.height = '1px';
			  document.body.appendChild(ad);
				var adBlockEnabled = !ad.clientHeight ? 'yes' : 'no';
			  tracker.set('dimension' + opts.dimensionIndex, adBlockEnabled);
			  document.body.removeChild(ad);
			});
			ga('require', 'adblockTracker', {dimensionIndex: 11});
      var currLocation = String(document.location);
      // strip out email addresses from location url
      var emailRegex = /([a-zA-Z0-9_\.-]+)@([\da-zA-Z\.-]+)\.([a-zA-Z\.]{2,6})/i;
      var cleanPageLocation = currLocation.replace(emailRegex, "");

      ga('set', 'location', cleanPageLocation);
			ga('set', 'anonymizeIp', true);
			ga('newTracker.set', 'location', cleanPageLocation);
			ga('newTracker.set', 'anonymizeIp', true);
				ga('send', 'pageview');
				ga('newTracker.send', 'pageview');</script><script>var chartbeatUser = ( readCookie("syncwall-authToken") == null ) ? 'anon' : 'paid';
	        var _sf_async_config = _sf_async_config || {};
	        _sf_async_config.uid = 57640; _sf_async_config.domain = 'swiftcom.com'; _sf_async_config.useCanonical = true;
	      	_sf_async_config.sections = 'ParkRecord.com,news';
	      	_sf_async_config.authors = 'Jay Meehan';
	        _sf_async_config.title = 'Jay Meehan: Viva Mexico, and throw the bums out | ParkRecord.com';
	  			var _cbq = window._cbq = (window._cbq || []);
	      	_cbq.push(['_acct', chartbeatUser]);
	        (function(){
	          function loadChartbeat() {
	            window._sf_endpt=(new Date()).getTime();
	            var e = document.createElement('script');
	            e.setAttribute('language', 'javascript');
	            e.setAttribute('type', 'text/javascript');
	            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
	            document.body.appendChild(e);
	          }
	          var oldonload = window.onload;
	          window.onload = (typeof window.onload != 'function') ?
	              loadChartbeat : function() {
	                  oldonload();
	                  loadChartbeat();
	              };
	        })();</script><script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://cdn.parkrecord.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://cdn.parkrecord.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img,iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );

	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };

	observer.observe(b, config);
}, false);</script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1568813782 -->